Malware Managed

My Account

Cylance PROTECT System Compatibility and Requirements

Note: It is recommended that system hardware (CPU, GPU, etc.) meets or exceeds the Recommended Requirements of the target operating system. Exceptions are noted below (RAM, available hard drive space and additional software requirements).


 

Operating Systems:

Windows XP SP3   (32-bit & 64-bit) - with KB 968730 hotfix installed *
Windows Vista   (32-bit & 64-bit)
Windows 7   (32-bit & 64-bit) - including Windows Embedded Standard 7
Windows 8 and 8.1   (32-bit & 64-bit)
Windows 10   (32-bit & 64-bit) - Agent 1310 or later

Windows 10 Anniversary Update  (v1607) is supported with Agent 1400+. See the Notes section below for more details.
Windows 10 Creator Update   (v1703) - There appears to be PowerShell scripts detection issues with Windows 10 v1703. See the Notes section below for more details.

Windows Server 2003 SP2 (32-bit & 64-bit) - with KB 968730 hotfix installed *
Windows Server 2008 (32-bit & 64-bit) and 2008 R2 (64-bit)

Windows Server 2008 - Server Core is not supported

Windows Server 2012 and 2012 R2 (64-bit)

Windows Server 2012 and 2012 R2 - Server Core and Minimal Server Interface are not supported.)

Windows Server 2016 - Agent 1410 or later. Supports Standard, Data Center and Essentials.

Windows 2016 Nano Server is not supported

Mac OS X 10.9
Mac OS X 10.10
Mac OS X 10.11 - Agent 1310 or later
macOS Sierra (10.12) - Agent 1410 or later
RHEL/CentOS 6.6 - 32-bit and 64-bit **
RHEL/CentOS 6.7 - 32-bit and 64-bit **
RHEL/CentOS 6.8 - 32-bit and 64-bit **
RHEL/CentOS 7.0 - 64-bit **
RHEL/CentOS 7.1 - 64-bit **
RHEL/CentOS 7.2 - 64-bit **
RHEL/CentOS 7.3 - 64-bit **
RHEL/CentOS requires Agent 1430 or later

* For Windows XP and Windows Server 2003, the hotfix in Microsoft's KB 968730 resolves a communication issue with the Console. These older operating systems can have issues obtaining a certificate if the certificate authority (CA) uses SHA256 encryption or higher. Cylance is required to use this level of encryption to meet Microsoft security requirements.

** For RHEL/CentOS 64-bit systems, the Agent is a 32-bit binary and requires 32-bit libraries to run. Make sure all dependencies are installed before installing the Agent. See the Linux Agent Installation article for more information. 

About End of Support for operating systems:

Cylance does not anticipate ending support for any of the currently supported operating systems. Cylance will do its best to ensure that all new features work across all supported platforms. This may not always be possible as vendors stop supporting their products or if the security risk is too high to continue supporting older platforms. Any time Cylance products or features do not support a specific platform, advanced notification will be provided.

About Support for new operating systems:

Cylance strives to support new operating systems as soon as the OSes are released, to help ensure coverage for our customers. To support a new OS, our Engineering and QA teams need access to a build and run through a full suite of tests to ensure there are no issues. Cylance tests using beta builds of the OS, but changes between the beta and the final release of the OS can introduce new issues that must be addressed and fully tested.

Memory:

2GB

Available Disk Space:

500MB (Note: Disk space usage can increase depending on features enabled, like setting the log level to Verbose.)

Additional Requirements:

.NET Framework 3.5 SP1 or later (Note: .NET 4.0 must be the full version, not the .NET 4 Client Profile.)
Internet Browser
Internet connection to register the product.
Local Administrator rights to install the software
See this article for additional software requirements for older operating systems (Windows XP and Windows Server 2003).

Notes:

Support for Windows 10 Anniversary Update

Microsoft Windows 10 Anniversary Update is supported with Agent version 1400 or higher.

Microsoft Windows 10 Device Guard and Credential Guard are supported with Agent version 1410 or higher.

Microsoft has also introduced a beta version of Windows Subsystem for Linux (WSL) in the Windows 10 Anniversary Update. WSL lets users run a bash shell on Ubuntu on Windows and has been received very positively by the developer community. WSL is disabled by default and Microsoft is likely to introduce more features before it becomes generally available. Cylance is following these updates and will introduce necessary controls for WSL when it becomes mainstream. Until then, Cylance recommends disabling this feature.

Support for Microsoft Windows 10 Creators Update (Windows 10 version 1703)

For the Microsoft Windows 10 Creators Update (v1703), there appears to be PowerShell scripts detection issues. Cylance is investigating the issue and plans to resolve this issue with the Agent version 1440 release.

Note: Windows 10 Creators Update has the same known issues as the Windows 10 Anniversary Update.

.NET Framework 4 Client Profile

Agent version 1400 will show as offline if the device is using Microsoft .NET Framework 4 Client Profile. To resolve this issue, install the full version of .NET 4.0 (or higher).